Aquarium Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
ive got a 10gal tank with four mystery snails, two lamp eye tetras and a neon tetra. The filter is rated for a 30gal tank. The water is cloudy ive used bacteria formula to start things off . Could the snails be giving off too much waste or too many in tank the set up is about 2 weeks old
 

·
Registered
Joined
·
190 Posts
idk know much about fresh water, but does it look like you have pored a bit of milk into the tank, is what color the water looks? I would try a few water changes and if that doesn't help usually the cloudy water sometimes means you will need a UV sterilizer but thats in SW and I don't know anything about FW, so I would research it.
 

·
Registered
Joined
·
14 Posts
Get some of that bio bacteria. Do a water change of 25% every day. It will clear up over time as the filter starts doing it's thing, and the bacteria get established.....When it comes time to clean the filter, don't do too good of a job......leave it a little messy........z
 

·
Registered
Joined
·
1,048 Posts
Cloudy water is something that sometimes happens to new tank give it a few days to see if it clears up. You tank is no where near being cycled to support Apple Snails as they are sometimes sensitive to water quailty. Ammonia. You should have a liquid test kit and test you water daily and do a 20 to 25% water change with out vacumming the gravel when the Amm. get to high., Read up on cycling a aquarium, you will understand quickly what to do. What product did you use to dechorinate the water you put in the tank?
 
1 - 4 of 4 Posts
Top