Aquarium Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I’m Josh. I’ve enjoyed freshwater aquariums off and on my whole life. After buying my first home a few years ago my father offered me a 75 gallon aquarium he doesn’t use anymore. I gratefully accepted and filled it up with my city tap water and slowly began adding fish over time. Things went great for a couple months as they did previously in my life when I had freshwater fish aquariums before. When fish began to die I did a lot of discussing with my dad who gave me some advice and water test kits. I found that the pH of the aquarium water and my tap water was over 8.2. I was also using tap water that did not go through the water softener. I eventually ended up with just a pleco and a few surviving rainbows in my aquarium and had lost my angels and swords. My dad gave me his RO water filter and I began using RO water in my aquarium fixed with the appropriate amount of RO right and pH stable. I started this with weekly 15 gallon water changes in my 75 gallon tank and after a few weeks started doing it twice a week. I’ve been doing this for several months now to where I’m certain my aquarium water is now only composed of RO water with pH stable and RO right added to it. To my constant frustration my tank water always reads a pH of 8.0 and after a water change 7.7 to 7.8. I’d like to get my water stabilized at around 7.5 before ever adding fish again. I’m am at a standstill and joined this forum to ask for advice/help.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Yes I have two power heads one at each end attached to under gravel filter. No bubblers but I have two double wide water filters running with two bio wheels each.
 
1 - 4 of 4 Posts
Top