Aquarium Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello guys. I recently took my friend's aquarium because he is going out of the US and I offered to take care of it. I don't know what he did and what kind of fertilizer or other stuff he used, but I do not like what I am seeing. The plants are not as they were supposed to be, and I have never seen something like this. Personally, I use fertilizers I buy on Amazon, Green Leaf Aquarium, and NilocG. The last one is the most used one by me, and my other two tanks are looking great. Now, this tank is a freshwater one, and I do not know if I am supposed to use any aquatic plant product at this point or change all the tank's setup. I am attaching some pictures, hopefully, they are clear pics that I took the moment I received the tank. Don't worry about the fish, they are moved to another tank, a smaller one, temporarily.

Did anyone of you have this same problem? How did you resolve this? Do you suggest me investing in improving this actual setup, or maybe changing it completely? What is the most logical, less time-consuming, cost-effective solution?

If the pics are not very visible, note that the rocks are turned black and the plants, brown shade! Also, the pressure of the switching pump was not proper, and I changed it. I know that this does impact, but I am not sure about the fertilizer stuff.

Thank you in advance!

31667


31668


31669


31670


31671


31672
 
1 - 1 of 1 Posts
Top