Aquarium Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I have a 12g nano tank with 2 18w cpf bulbs in a cannopy that came with the tank, well every time i turn on my lights the fans make this horrable buzzing noise like they are grinding on somthing but theire not???im not really sure what is wrong with them. i tried finding replacement fans but i cannot find the right size needed for my tank. Every time this happens i smack my hood and it stops for a couple of seconds then starts again.what is wrong with them, and how can i fix this????:confused:
 

·
Registered
Joined
·
1,048 Posts
bad bearing/or seal in the fan motor....... call the manufactor and they should be of some help. This is my main reason for not liking all in one units.... one thing breaks everything has to removed to fix it. I have a light fixture that did that and for a long time I just blow it clean with compressed air and then added a very small drop of 3 in 1 oil. it worked for awhile but ended up having to replace the fan..... I don't have the site any more where I got the fan, but like I seid, call the menufactor and they should help.
 

·
Registered
Joined
·
2 Posts
The blades could be dirty or the fan could be on its way to seizing up. You can try to clean it and oil it or contact who you bought it from to get a replacement fan.

A lot of times these fans are just DC computer fans and shouldn't be that hard to find either locally or online.

If you could list the make and model of your lights some one could get you pointed in the right direction.
 
1 - 3 of 3 Posts
Top