Aquarium Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Greetings All! My name is Alex and I live in Houston, TX (originally from San Antonio but moved here for work). I've had a ten gallon aquarium for about a year and it is definitely a learning experience but as I recently found out apparently I have not learned enough.

Anywho, a little background: in January of '09 my dad bought for my then 4 year old son two goldfish that apparently he bought from Wal-Mart. They came in a plastic carrier and as my dad handed them to me he said, 'there's no need to get a tank". Well about two days later that carrier and the water was absolutely filthy so I decided to get a tank so these fish could have a proper home. I thought it would also be nice decoration for my son's room and he could start to learn about being responsible for a pet (figuring a fish tank should be pretty simple compared to getting a dog or cat). Long story short, it is now a year later and we now have two tetras and a molly (the goldfish didn't make it).

I am currently having an issue with rising nitrite levels after I recently installed a new power fiter (aquaclear 20 to replace the crappy TOP FIN pump that came with the petsmart kit). Anywho, it's great to be involved with a message board that doesn't involve University of Texas athletics. I'll start a new thread for my nitrite problem so be on the lookout if you're interested in helping a noob.
 

·
Registered
Joined
·
1,770 Posts
Welcome to the site!
 
1 - 3 of 3 Posts
Top