Aquarium Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
i have a small "dazs" glass co2 diffuser, and the lines connected but no gas is coming through the ceramic disc, iv even gone up to 15 psi, im afraid im gonna break the glass, no matter what pressure i use low to high i cant get the dang thing to work >.> any ideas? did i just get a bad one?
 

·
Registered
Joined
·
1,048 Posts
Is this a injection system......or yeast...

I not sure I thought you were using a yeast, on a tank.

anyway, those defusers send out very fine bubbles and will only work with an injection system because it needs high pressure to push the gas thur... On an injection system IMO it best to use a CO2 reactor it get about 98 to 99 percent absorbtion rate, so they say. You can buy them from Floridadriftwood.com aquariuplants.com and red seas has one, but these all go inside the tank. You can build one out PVC pipes that you can store under the cabinet and it would be unseen. On a yeast system for smaller tanks a powerhead works but I perfer the ladder, I find it relaxing.... it is a little unsitely, but like I seid it relaxing.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
im using yeast, but i tried it with my 20OZ co2 bottle wich i have a regulator for, and i still didnt get any thing, i ran the pressure up and still didnt get any bubbles. im thinking i got a bad one?
 

·
Registered
Joined
·
24 Posts
Discussion Starter #7
i had it preasurized with gas for about 2 hours and i didnt get any thing, not even the smallest bubbles absalutly nothing. and it was at around 15 psi i would guess
 

·
Registered
Joined
·
24 Posts
Discussion Starter #9
when your on the fourm ur in a section, say freshwater planted aquriums on the left at the top their is a "new thread" button click it then u have a new thread
 
1 - 10 of 10 Posts
Top