White fuzzy stuff - Aquarium Forum
Freshwater Fish Diseases, Algae Problems, and Tank Emergencies This is a place to chat about different ailments of freshwater fish, as well as tips on how to control algae, and other topics about keeping your fish tank healthy. If you're having problems keeping your fish healthy, or the fish don't seem to be well, of you have some other type of emergency, this is the discussion board to post in. Our community of members will promptly give you guidance.

  Members currently in the chatroom: 0
Who's Online
The most chatters online in one day was 17, 09-12-2012.
No one is currently using the chat.

LinkBack Thread Tools
post #1 of 2 (permalink) Old 11-20-2010, 11:30 AM Thread Starter
Join Date: Oct 2010
Location: Huntsville, AL
Posts: 391
Welcomes: 192
Welcomed 11 Times in 1 Post
Thanks: 14
Thanked 69 Times in 69 Posts
White fuzzy stuff

So, I have something growing on the new log and a few plants I have in my tank. I think I saw it in my tank before adding the log, it just seems to be growing best there.

Is this some form of algae or bacteria? I can break it up by rubbing on the wood, but it is not really something I can grab onto. It seems like a mold-like substance.

Any ideas? How to get rid of it?
This tank is not yet established.. still cycling, so I hate to disturb the bacteria growth, but I worry about a tank full of cotton

Also, I'll mention this is my "beaslbob build" so it doesn't have real filtration, just an airstone in there right now. The white specks in it seem more like waste or dirt than anything alive.


30G AquaClear50: Lightly planted, platies, ottos, kuhli loaches.
10G Sponge filter: Heavily planted, ottos, red cherry shrimp
mfgann is offline  
Sponsored Links
post #2 of 2 (permalink) Old 11-20-2010, 01:18 PM
....has no life....
jrman83's Avatar
Join Date: Jul 2010
Location: White Plains, MD
Posts: 12,629
Welcomes: 5,131
Welcomed 0 Times in 0 Posts
Thanks: 746
Thanked 4,635 Times in 3,785 Posts
Re: White fuzzy stuff

If it is new driftwood, it's normal. Should go away after a couple of weeks.
jrman83 is offline  

Quick Reply

Register Now

In order to be able to post messages on the Aquarium Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome